wiki:UserGuide

User Guide

Below you'll find a quick start for both administrators and users. We assume that you've installed Proteios SE successfully. Also the proteios servlet and ftp service must be running. Follow the steps in the below quick start to get a feel for the application. When you want to learn more about specific features, click the links below. For optimal appearance of the web interface we recommend the Firefox web browser, even if other browsers also should work. For Firefox we also recommend the FireFTP plugin which integrates an FTP client which works fine with Proteios SE.

Note on Menu System

The main method of navigation in Proteios SE is via the drop-down menu tool bar at the top. A menu is displayed when the mouse pointer is placed on the menu title, and stays up as long as the mouse remains within the menu. A hierarchical (cascade) menu item is indicated by a blue arrow to the right of the menu title; placing the mouse pointer on the menu item makes the sub-menu appear, which might contain further hierarchical menu items. Selecting menu item Start Here in menu File is indicated as File -> Start Here in this documentation.

The Project menu changes name to that of the active project, as soon as one has been selected, and its menu items then refer to this project. The Project menu for an active project is indicated as <Active Project> in this documentation. As an example, if the active project selected has name "Test Series 12", you can inspect the files belonging to the project by selecting menu item Files in the menu named Test Series 12, which will be indicated as <Active Project> -> Files in this documentation.

To simplify navigation for often used tasks, the menu system contains shortcuts such as the File -> Select project to change the active project, and Files -> New for creating new items. In the examples below, only one way of how to perform the desired task is shown in these cases.

For Administrators

  1. User account administration
    1. Login with the root account
    2. Select View -> Users then click New User
    3. Fill out all blue (required) fields
    4. Make sure the User role is checked and click Save
  2. Adding extensions
    1. Place your extension EXTENSION.ext.jar in /path/to/proteios/WEB-INF/lib/
    2. Restart tomcat
  3. Plugin handling
    1. Login as root.
    2. Select View -> Plugins to activate all available plugins
    3. Check the checkbox of a plugin and select Delete to inactivate the plugin
    4. Check the checkbox of an inactive plugin and select Restore to make it active again.

For Users

  1. Working with projects
    1. Login with a User account
    2. Select File -> New -> Project
    3. Fill out the form and click Save to create the project and make it active after which the name of the Projects menu changes to that of the project
    4. Use File -> Select project or View -> My Projects to select an existing project
  2. Working with files
    1. Browse to a directory from <Active Project> -> Files
    2. Upload a file using Upload file
    3. Use an ftp client to upload your files
  3. Samples and activity tracking
    1. Select <Active Project> -> LIMS -> Samples and click New Sample
    2. Fill out the form and click Save
    3. Switch to the annotations tab and add an annotation
    4. Switch to the properties tab and Make Extract
    5. Fill out the form and click Save
    6. Select New Separation Event.
    7. Select gel electrophoresis.
    8. Create a new gel.
  4. Protein identification reports
    1. Select <Active Project> -> Files then select Extensions -> Upload demo files for gel-based project
    2. Select <Active Project> -> Hits Import -> Gel Based
    • Step 1: Select spot picker results file
    • Step 2: Select peak lists files
    • Step 3: Select search results
    1. Filter the hits report by E-value
    2. Save the filtered report to file
  5. Browsing search results
    1. Select View -> Imports -> Searches
    2. Select a search result
    3. Click on an identified protein
    4. Go back and click on an identified peptide
  6. Sharing information
  7. Label free quantification
  8. Feature Detection
  9. Hits comparison report
    1. Select <Active Project> -> Reports -> Hits Comparison
  10. Logging out
    1. Select File -> Logout

Activities

Most of the work in Proteios SE is performed by various plugins. These are executed sequentially in a job queue. To follow the activities in the job queue, select View -> Jobs. Note that the status reported in the job table will not update automatically when the job status changes. To follow the execution of a job, click Update to update the displayed information. For more information on how to follow a job, see Following a Job.

Running plugins

There are several options on how to run plugins, depending on their input and output parameters. Many plugins are using a file as only input parameter. To execute such a plugin, click the checkbox for the file in the file view, after which the "Extensions" toolbar button is pressed to make a pop-up menu with available plugins appear, then select 'Import file[s]' and the name of the plugin. Some plugins require additional parameters, in which case a more specialized item in the extensions menu has to be selected.

Peak List Sets

In many cases it is not necessary to import the peak lists into the database, but it is enough to upload the peak list files to the Proteios server. However, some analyses require the files to be imported into the database. To import a peaklist into the database you should run the appropriate import plugin on the file (see Running plugins).

Specific tools

DIGE Analyzer Running dye effects analysis on a set of DiGE gels.

ExQuest spot cutter import How to import spot mappings from ExQuest.

Spectrum library export Exporting spectrum libraries.

Last modified 7 years ago Last modified on Mar 11, 2011, 4:07:46 PM