wiki:Releases

Proteios Software Environment releases

Also see the roadmap

Current release : Proteios SE 2.19

Release date: 2013-10-24

New Features:

  • Generation of ProteomeXchange submission (px) files for a project. The px file is based on project description, selected files, and sample and file associations.
  • Support for comparison of technical replicates
    • Results import using file replicate annotations.
    • Merging or comparison of technical replicates in reports depending on selected options.
  • Project home view now contains common actions for label free workflow
  • Administrator can now enforce password change at next login

Improvements of existing features:

  • PRIDE export enhancements
    • Export of modifications including site
    • Export of MGF-based results (including conversion of spectra to mzData)
    • Instrument info retrieved from associated mzML
    • Export of multiple samples at once.
    • Reporting of used search engines.
  • Mascot searching and import updated to support Mascot Server 2.4
  • Mascot search interface updated to show all selected modification even with non-standard characters.
  • It is now possible to define file-sample associations from the file side.
  • mzML reader updated to support MS Numpress numerical compression
  • msInspect launcher updated not to use feature filter by default.
  • Selection of file for protocol updated.

Full ticket list for this release.

Past Releases

Proteios SE 2.18

Release date: 2013-03-15

New Features:

  • Spectrum viewer zoom range can now be set using mouse, and is shown in original spectrum.
  • Basic authentication support for Proteios SE web service.

Improvements of existing features:

  • Alignment of features for label free quantification now falls back to features without identities when not enough common identities in two files for alignment.
  • Quantitative hits comparison updated to work better when data sets are large.
  • Job table content is now updated at regular intervals for existing rows.
  • MGF reader updated to support scientific notation of precursor intensities
  • Now possible to remove sample-file association
  • Install scripts for Linux improved to use settings from previous installation, etc.
  • Hibernate (database access) is updated to version 3.6.10.Final (last 3.* version).
  • Various updates/fixes in order to improve the stability of the software.

Full ticket list for this release.

Proteios SE 2.17

Release date: 2012-11-09

New Features:

  • Introduction of mechanism for distinction of technical replicates
  • Propagation of feature identities using novel alignment algorithm
  • Comparative report of MS1 peptide features from different files
  • Reporting of delta score for Mascot and X!Tandem modifications
  • Publishing of files from the http://bils.se BILS proteomics pipeline at the Swestore storage
  • Export of peptide reports for PQPQ analysis Forshed et al 2011

Improvements of existing features:

  • Optimisations for handling of large datasets. Less data is now imported into the database from search results, and combination of search results is now much faster.
  • Upgrade of OpenMS integration to support version 1.9

And several bug fixes

Full ticket list for this release.

Proteios SE 2.16

Release date: 2011-06-21

New Features:

  • OpenMS feature detection results can now be imported.
  • Spectrum searches and feature detection now has the option to automatically import uploaded results.
  • Feature detection can now be started from the project menu, in analogy with spectrum searches.
  • Protein assembly can now be performed for all samples in one go.
  • Extensions requiring external programs to work, may now be configured to be disabled.

Improvements of existing features:

  • Running OpenMS feature detection from Proteios SE now allows more parameter values to be set.
  • Proteios SE FTP server now saves uploaded files compressed, unless compression size gain is < 20%.
  • Mascot search jobs can now be aborted.
  • Mascot and X!Tandem search jobs now give basic progress info of major process stages.
  • Improved feature matching to MS/MS identifications.
  • Features and hits can now be matched from different files.
  • MIME type is now set for created text files, allowing them to be inspected directly.
  • Jobs in a blocker chain are now moved together to the High Priority Queue.
  • Executing jobs may now be moved to the High Priority Queue, provided the latter is empty.
  • Various updates/fixes in order to improve the stability of the software.

Full ticket list for this release.

Proteios SE 2.15

Release date: 2011-03-16
New Features:

  • Quantitative hits comparison report introduced. It is used to compare peptide or protein concentrations between sample collections. It is complementing the existing hits comparison report, and is accessed from the same menu entry.
  • Feature detection can now be performed using external programs msInspect and OpenMS, directly in batch from Proteios SE.
  • Demo files for non gel-based projects are now available, and can be uploaded to an active project using a new file context extension.
  • LIMS information about files can now be used to automate sample assignment of peak lists when registered using the non gel hits import. Local sample id and fraction information are derived from the file annotations.

Improvements of existing features:

  • Hits comparison in peptide mode now has an option to include peptide modifications.
  • Protein quantification using isobaric labels has been updated with an option to only use peptides that are unique to a protein group.
  • Management of annotations has been improved, simplifying editing and deletion of annotation values.
  • The Proteios SE favicon shown in the web browser url field and tabs has been updated from the previous blank icon. This makes it easier to find the Proteios SE tab, when many tabs are open.
  • Support for viewing text-based files has been extended in the file properties form, in that more MIME types are recognized. Also, a warning is now displayed if the user tries to view a large file.
  • Various updates/fixes in order to improve the stability of the software.

Full ticket list for this release.

Proteios SE 2.14

Release date: 2010-12-08
New features:

  • Features from msInspect can be imported and matched to peptide identifications, providing precursor quantities to the hits.
  • Possibility to remove erroneous hits input
  • Enabled extensions for hits table
  • Collapsable fieldsets in forms enables hiding of advanced features
  • Introducing FileTypeContext?

Several bug fixes and improvements, in particular:

  • The "Select Project" menu will now only contain 20 project items.
  • Improved project removal
  • Improved support of Mascot
  • File table "Move" command fixed to allow a large number of files to be moved with a single command.
  • Extension for viewing spectra in a spectrum file now made a core extension.
  • Button icons for disabled buttons are now displayed in grayscale.
  • Class FormFactory? has been refactored to only create generic forms
  • More stable FTP server
  • Installation under Microsoft Windows updated to be more supportive of spaces in directory names.

Full ticket list for this release.

Proteios SE 2.13

Release date: 2010-08-23
New features:

  • Support for Mascot 2.3 server
  • Protein level FDR filtering in protein assembly. Based on target-decoy approach.
  • PRIDE export of non-gel results with improved functionality.

Several bug fixes and improvements, in particular:

  • Hits comparison report corrected and improved.
  • Bugs in several list views corrected.
  • Help messages added.
  • Job queue layout improved.

And a lot of code cleanup and build improvements.

Full ticket list for this release.

Proteios SE 2.12

General improvements and bug fixes to:

  • FTP server
  • Wiki
  • Code cleanup

Some specific functionality improvements:

  • Calculated combined false discovery rate is not set to zero anymore, but rather estimated as 1/total number of peptide/ protein ids as lowest.
  • Protocols can now be shared to all users.
  • Samples and files can be automatically linked and annotated by parsing of uploaded info files.
  • Administrator home view for administrator (root) user.
  • Help text added to form fields.

Full ticket list for this release.

Proteios SE 2.11

Release date 2010-02-18
The release includes the following new features since the previous release:

  • Simplified Linux and Windows installation and update procedures.
  • A new format for the protein assembly report with quantitative information.
  • Export of TraML (http://www.psidev.info/index.php?q=node/405) inclusion lists based on peptide identifications.
  • Generation of zip archives of user files.
  • Usage of remote files with https URLs using certificates.
  • Improved protein list comparisons

Full ticket list for this release.

Proteios SE 2.10

Release date 2009-12-14

  • Improved table management
    • The display order of columns can now be set by the user.
    • The order in which table contents are sorted after selected columns can now be set by the user.
    • Columns representing files can now be filtered on the filename.
    • Optional storage of table preferences made by the user in the GUI, for automatic loading when the same table is shown again. The option can be activated in menu item "File -> Preferences...".
  • Deletion of project contents
    • It is now possible to schedule all content of a project for deletion
  • Simpler alternative start of protein identification search engines
    • Spectrum file searches can now be started from menu item "Spectrum Search" in the menu for the active project.
  • Improved spectrum viewers
    • Spectrum viewers now show the mass value as tool-tip, when the mouse pointer is in the vicinity of a mass peak.
  • Access of Protein 3D data from Hits table updated to be compliant with changes in some of the third-party web pages that are parsed for web links to 3D data .
  • Support for compressed files
    • A file can now be stored in compressed format internally, in order to save server disk space (can be changed at any time). Registering a remote file as compressed will make a requested download stream to be decompressed.
  • Emptying of trash can as a job in order to not lock the GUI
    • If any SpectrumSearch item or more than 10 other items should be removed, a job is now created.
  • Proteios FTP server now supports shared directories
    • Project directories of shared projects can now be found under directory entry "_Shared_Projects".
    • When the contents of a project directory is listed, the FTP server attempts to also list directories shared to the project.
  • Features from label free LC-MS can now be imported into a dedicated table
  • pI and Mw info is now added to proteins in Protein Assembly.
  • Samples can now be tracked through fraction collection
  • Files can now be annotated
  • GET requests support cross table filters
  • Ownership of created items may now be set to another user than the authenticated one
  • Bug fixed for setting properties of items inside a project

Also see the complete ticket list.

Proteios SE 2.9

Release date 2009-10-12

  • Enhancements to job handling
    • Several plug-ins that access external web sites to obtain information have been updated to allow a job to terminate directly after an abort command is given.
  • Extended search engine access
    • OMSSA search updated to allow an mzData file as input, using a work flow with conversion to an intermediate MGF file.
  • Improved spectrum viewers
    • Spectra can now be zoomed by entering values for low and/or high mass limits.
    • Improved display of spectra with few peaks, now shown as lines instead of bars.
    • Spectrum file viewer now has buttons for selecting previous or next spectrum in list.
    • Spectrum file viewer now has page-managed spectrum list table if number of spectra in file is large (> 20).
  • Batch import of samples, extracts, and labeled extracts from input files in tab-delimited format.
  • Enhanced MIME type management
    • Extension for setting same MIME type for several files.
    • Proteios FTP server now attempts to set MIME type for uploaded file.
  • Access of Protein 3D data from Hits table updated to make parsing of link info in external web pages more flexible to changes in the format of the latter.
  • Administrators can now list active users
  • Enhancements to simplify future Proteios SE development
    • Uploaded files are now distributed into several sub-directories in Proteios SE user files directory.
    • Proteios version specification extended with optional marker to inform users if they are running on e.g. a development (trunk), alpha, or beta software version.
    • Updates of some used external libraries.

Also several bug fixes, including:

  • Misleading error messages when creating project with duplicate names
  • Wizard forms in several steps included a duplicate menu when hitting Enter

Also see the ticket list

Proteios SE 2.8

Release date 2009-07-10

  • Extended search engine access
    • Batch searching in Mascot and import of results.
    • File extensions added for finding original search results for Mascot or X!Tandem searches.
    • Search engine settings can now be shared with another user.
  • Enhancements to job handling
    • Several jobs can now be executed simultaneously (one per job queue).
    • Better distribution of jobs in job queues (jobs using third-party resources are placed in slow-job queue).
    • Job queue status information now includes number of pending jobs for all users, and number of pending jobs for other users before first own pending job.
  • Administrators will now see jobs for all users.
  • Improved spectrum file handling
    • Precursor fragmentation type, possible charge states, and multiple selected ions are now shown for mzData and mzML files, if supported in the latter.
    • Extra data stored in cvParam tags also shown for spectra.
    • mzML files can now be used as peak lists in the hits report.
  • Hits comparison report creation added, allowing comparison of peptide and protein identifications beween samples, projects, fractions etcetera.
  • Project properties extended
    • Non-gel or gel-based project selection, affecting the default columns shown in hits report.
    • Projects can now be closed.
  • Protein assembly extended
    • Minimum number of peptides added as option.
    • Reporter ratios can now be collected from adjacent scans for TMT / iTRAQ experiments.
  • Clicking search result file cell in the protein identification table now displays search results.
  • Non-gel import made more flexible when extracting fraction Id value.

And a couple of important fixes:

  • Stability fixes.
  • Fixes related to project sharing.
  • Fixes in the protein assembly - proteins no longer appearing in more than one group.

Also see the ticket list

Proteios SE 2.7

Release date 2009-05-07

  • Improved web service
    • Better support for file upload and external referencing
  • Enhancements to job handling
    • Several job queues are now supported, including one high priority queue
    • Jobs can now be aborted and deleted
  • Improved spectrum file handling
    • Sample and contact info can now be added to mzData and mzML files
    • More information displayed for mzData and mzML files and spectra
  • Access to protein 3D structures from http://cathdb.info/ from the protein identification table
  • More user friendly error messages
  • Various user interface improvements

And a couple of important fixes

  • Security and stability fixes
  • Fixes related to project sharing, including plug-in updates for shared projects

Also see the ticket list

Proteios SE 2.6

Release date 2009-02-18

  • PRIDE export
    • Filtered identifications and peak lists can now be exported to a PRIDE 2.1 XML file
    • Both gel- and non-gel export

  • Support for isobaric labels TMT and ITRAQ added to protein assembly report
  • mzML 1.1.0 support
    • Converters updated to produce mzML 1.1.0
    • Readers updated to read mzML 1.1.0
  • Users can now select what score types to use when combining search hits
  • Simpler script for updating Proteios SE to new version, with reuse of configuration data
  • Various updates to the graphical user interface
    • Single hit data is now showed as a table, allowing more information and cell-associated links
    • Extension for setting same file type for several files
    • Various updates of menus intended to increase consistency and to simplify use

Also see the ticket list

Proteios SE 2.5

Release date: 2008-11-26

  • Extended search engine access from Proteios SE
    • Batch retrieval of Mascot search results from Mascot Server
    • Batch searching in OMSSA from Proteios SE and import of results
  • Improved search results combination
    • Algorithm changed for better scalability with many search engines
    • Peptide level combination improved
  • Protein function annotation
    • Protein function annotation using the PIKE service, directly from Proteios SE
  • Protein inference
    • Inference of proteins from filtered peptide lists, including combined search results
  • Exclusion list generation
    • Generation of exclusion lists for LC-MS/MS from search results, including combined search results
  • As well as improvements to existing functions:
    • Spectrum file readers now also obtain and display precursor information
    • Exporting table data to file can now be done for either displayed data or all data
    • Support for moving several file items in batch mode
    • Option to save an edited X!Tandem search parameter set in new file

Also see the complete ticket list

Proteios SE 2.4

Release date 2008-09-16

  • Layout of graphical user interface changed to comprehensive workbench format
  • Improved support for fine tuned project sharing and sharing of files and directories from the graphical user interface
  • Wizard for a quick introduction
  • Better support for import and reporting of LC-based MS experiments, including combination of search results from multiple search engines.
  • Batch X!Tandem searching which interrogates GPM server for possible search parameter alternatives. Also support for selection of k-score scoring algorithm.
  • Peak list file conversion to, and reading of, mzML.
  • E-mail notification of job completion.
  • Enhanced web service with POST method.

Proteios SE 2.3

Release date 2008-05-28

  • Sharing information between project members
  • FTP server updated with passive port range, new start/stop
  • X!Tandem spectrum searches using interface to GPM web site
  • Mass spectrum plots now show mass values for some peaks
  • Extension for viewing mass spectra in files
  • Gel viewer
  • Bug fixes and more...

Proteios SE 2.2

Release date 2008-03-19

  • LC-MS comparisons
  • GUI improvements such as the floating popup window
  • Enabling '*' wildcard in filters
  • Bug fixes and more...

Proteios SE 2.1

Release date 2008-01-15

  • Better protocol support
  • DiGE analysis
  • Several improved GUI features
  • Beta webservice feature for access using other clients

Proteios SE 2.0

Release date 2007-11-01

Proteios 2.0 beta 2

Release data 2007-10-04

Proteios 2.0 beta 1

Release data 2007-08-31

Last modified 3 years ago Last modified on Oct 29, 2013, 9:50:45 AM