Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#431 closed (fixed)

Proteios demos server stack trace for IPGs

Reported by: jari Owned by: olle
Milestone: Proteios SE 2.4 Keywords:
Cc:

Description

Using the demo server as demo user I get a strack trace.

  1. Select project DEMO - Project
  2. Select IPG with external id IPG1, i.e., click on it.
  3. Voila, you will find the below output
  	

Message
    null
Stacktrace

    java.lang.NullPointerException
    	at org.proteios.action.gel.ViewActiveGel.runMe(ViewActiveGel.java:130)
    	at org.proteios.action.ProteiosAction.run(ProteiosAction.java:327)
    	at se.lu.thep.waf.Event.runAction(Event.java:275)
    	at se.lu.thep.waf.Event.go(Event.java:115)
    	at se.lu.thep.waf.ActionServlet.doGet(ActionServlet.java:84)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
    	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
    	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
    	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
    	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
    	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
    	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
    	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
    	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
    	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
    	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
    	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
    	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
    	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
    	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
    	at java.lang.Thread.run(Thread.java:595)

Change History (11)

comment:1 Changed 9 years ago by olle

Error analysis: The problem is caused by class/file action/project/ListIPGsInProject.java in client/servlet/ erroneously calling ViewGel.class instead of ViewIPG.class to view the data. Clicking the corresponding IPG1 link in the table displayed when listing IPG's for all projects (under Personal - LIMS - IPGs in the left panel) shows the correct information.

comment:2 Changed 9 years ago by olle

(In [2732]) Refs #431. Class/file action/project/ListIPGsInProject.java in client/servlet/ updated in protected method void runMe() by calling ViewIPG.class instead of ViewGel.class to view the data. Table variable name gelsTable changed to ipgsTable for clarity.

comment:3 Changed 9 years ago by gregory

  • Owner changed from gregory to olle

comment:4 Changed 9 years ago by olle

  • Status changed from new to assigned

Ticket accepted.

comment:5 Changed 9 years ago by olle

  • severity changed from 16 to 2

Severity set to 2.

comment:6 Changed 9 years ago by olle

Note:

The code change described in changeset [2732] should fix the problem for the trunk version of Proeios. However, the demo server, where the problem was discovered, normally runs the latest official release, which at the time of writing still is version 2.3. The next official release is version 2.4, with planned release date 2008-09-17. A decision must be taken whether to make a special bug-release before next official version, which will be used in the demo server, or wait to update the software in the latter until version 2.4 is released. Other possibilities exist, such as patching the software on the demo server without a special bug release, and documenting the change separately.

comment:7 Changed 9 years ago by olle

(In 49) Proteios home wiki page updated by adding link to new Known Issues wiki page to sections "Latest release" and "Documentation". Link to demo server moved to section "Latest release".

comment:8 Changed 9 years ago by olle

(In 1) First version of Known Issues wiki page with information on known issues with the latest stable release of Proteios. Initially only one issue regarding "Project IPG external ID stack trace" related to ticket #431 (Proteios demos server stack trace for IPGs) is reported.

comment:9 Changed 9 years ago by olle

(In 2) Proteios Known Issues wiki page updated. Section "Current Release" removed. Section "List of Known Issues" updated by adding "Version" column.

comment:10 Changed 9 years ago by olle

  • Resolution set to fixed
  • Status changed from assigned to closed

Ticket closed as the reported problem has been fixed in the development code, and the issue has been added to the Known Issues wiki page.

comment:11 Changed 9 years ago by olle

(In 10) Download wiki page updated by adding link to new Known Issues wiki page to section "Proteios *.*".

Note: See TracTickets for help on using tickets.